The O.G. Virtual learning! Buy one, get 2 more Lifetime Memberships! - Click Here!

Mark

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 25 total)
  • Posted in:
  • January 28, 2019 at 4:18 pm #203177

    Checked out Stack. Lot’s of information…

    I decided to remove the info.plist from Copy Bundle Resources under Build Phases.

    The project would build (with Project Setting on New Build…

    I then noticed under the Project files (left panel) in the project that info.plist did not have Target Membership with StoryTellerKit2 – checked it and it still builds (and the info.plist, which I removed, is added back into the Copy Bundle Resources).

    This solved the problem.

  • August 25, 2018 at 4:01 pm #186446

    To be more clear, it’s the scene editor window.

  • January 31, 2017 at 7:50 pm #160390

    That’s a good point. I’m sure after I spent all that time creating the movie I’d be driven mad once I found out how much size the app was – then go AWOL…

    Thanks for saving me!!!

  • January 30, 2017 at 6:39 pm #160274

    Okay, found the video tutorial! I’ll play around with it. Still not sure if it is quicker (more efficient) to create the animation in xcode or external using Flash or other animation software.

  • October 16, 2016 at 3:59 pm #157067

    Is it okay to have a launch screen with a Logo? Apple suggested that there should be no branding or logo on the launch screen. I just don’t want the app to be rejected if I have a launch screen.

  • October 5, 2016 at 1:48 pm #156672

    Awesome! Good luck on your App!

  • October 5, 2016 at 1:46 pm #156671

    Awesome! I’ll have to keep in mind the font bug!

  • October 4, 2016 at 4:53 pm #156634

    I did a quick test and mine ran fine – I tried both a .caf and .mp3. If I have this right, you have the Next button set to play the sound, then on the next page, the sound does not play when you press the Next button.

    I’m building for 10.0. What build are you building for?

    I’ve heard there is a bug in the new SpritKit that may cause this error. https://forums.developer.apple.com/thread/63532

    Mark

  • October 4, 2016 at 2:03 pm #156621

    I did a quick test with a large png (12mb) and had no problems. Is the delay in the simulator or device? The simulator is not the best place to test your code as it isn’t as smooth in the transitions. What version of Xcode/Swift?

    Here’s what I would try:
    1. A quick test would be to replace the current png with just a color Sprite.

    2. Place a “print” statement in the Plist after OpenPage and place a “print” statement in the OpenPage code. This will let you know if it has loaded and not displayed. If there is a delay in the “print” statement between the first print statement and the second, then its before the OpenPage execution. Then try #3 below.

    3. Have Cover go to Page 1 (bypass the menu). This would check if the menu loading is the issue.) If it works, then its in the menu transition.

    4. If in the menu transition, disable any actions (I put a “_” after an action (including narration) so it doesn’t get called – though you’ll get an error that it can’t find it but that is expected.) If that works, start adding each action one at a time until you find the source of the delay. If that doesn’t fix it I would start a new page (copy from a good page file) to replace the menu, then copy and paste the settings to build a new menu file.

    Hope this helps!

    Mark

  • October 3, 2016 at 2:28 pm #156589

    You can watch the Podcast at http://cartoonsmart.com/switching-from-swift-2-2-to-swift-3-in-xcode-8-episode-34/

    And if you want more information: https://swift.org/migration-guide/

    Hope that gets you going.

    Mark

  • September 30, 2016 at 5:37 pm #156475

    Found a way to do this. I added code for a PausePage and UnpausePage where I set self.isPaused = false, then add the UnpausePage in the Plist when I call the TouchEvent.

    Works like a charm!

    I’d still like to know how others are setting a pause/play/replay/home navigation scene.

  • September 30, 2016 at 5:33 pm #156474

    Ah, I thought that was the issue: hideNodeArray was commented out on the old version.

    Works now!

  • September 30, 2016 at 3:05 pm #156471

    Okay, now the download has the updated files and this download includes the StoryTellersKitTV (which it didn’t include before).

    Thanks!

  • September 29, 2016 at 3:05 pm #156415

    I tried to set the node to false in the PauseOrUnpausePage code but no action allowed to continue while in the page is paused. Only after I set self.isPaused = false will the page allow any actions.

    I’ve tried a few different ways and still not working. I think I will have to avoid the use of PauseOrUnpausePage and place all pause and unpause in each page.

    How are others using this feature? I know games pause the view and can have a few options to press. Could it be that they go to a different page where they pause the current scene then open a different page then do navigation from there?

  • September 29, 2016 at 2:00 pm #156413

    I updated the Page.swift code and replaced self.hideNodeArray.append(node) with node.isHidden = true – now it works fine.

    I downloaded the latest update and it still isn’t updated as Page.swift code is the same and the date stamp is August 23.

    Not sure why the current code loops through all the nodes to find the matching node.

Viewing 15 posts - 1 through 15 (of 25 total)



Know what an affiliate program is? You make money just by sharing links to our site! Win. Win.

Earn when you refer any buyer here! 30 day tracking. Commissions are 33%-50% and recur on subscription products!


Uh oh, missing your affiliate ID. Create one real quick