Player slows down and freezes in RPG kit after update

Home 4 Forums iOS / tvOS Starter Kits The Role Playing Games iOS and tvOS Starter Kit Player slows down and freezes in RPG kit after update

This topic contains 11 replies, has 2 voices, and was last updated by  Universe 2 weeks, 1 day ago.

  • May 2, 2018 at 9:34 pm #183533

    Trying to use RPG kit. Updated the player with the same size image atlases. Then made texture size slightly bigger. When i try to play on iOS, after walking for like 30 sec, the player slows down and soon freezes. Any ideas what to look for to get him back walking and fighting? Thanks!

  • May 3, 2018 at 12:52 pm #183562

    Is the sprite in the scene still the same size as the original images? Just wondering if thats causing some extra refactoring going on. You aren’t testing in the Simulator are ya?

    • May 3, 2018 at 7:29 pm #183568

      Yes, have tried on both – 3 devices and simulator having the same outcome.
      Now, I have changed back sprite size of the main player character w&h to 128, but the same outcome.
      Images are the same size as in standard kit: 2x 256 and 3x 384.
      Any ideas what else to check out? Thanks!

  • May 3, 2018 at 8:54 pm #183576

    Did you try going to Product > Clean Build Folder? feel free to Dropbox or G-drive me the project. I can always open and see if the same thing is happening here.

  • May 4, 2018 at 1:26 am #183584

    Yes, tried with Product > Clean too, but no luck. Have sent the project to you now. Thank you!

  • May 7, 2018 at 7:46 pm #183685

    Hi Justin – any chance to have a look? Did you get my mail last week? Thanks!

    • May 7, 2018 at 8:12 pm #183687

      I don’t remember seeing it. Did you attach the zip directly to the email?

  • May 7, 2018 at 8:17 pm #183688

    As g-drive shared link via email on May 4. Even got an Auto-reply. I forwarded again.

  • May 8, 2018 at 8:48 am #183696

    I deleted out the Yeti because it was a red X mark on my end. And it seems to play fine. Are your end, are you seeing that red X for the Yeti? If not, it probably means the art that got imported isn’t actually copied into the Xcode folder. Which is why I couldn’t see it, but you can. That could be whats causing issues.

  • May 8, 2018 at 7:57 pm #183709

    Still having the issue also after deleting Yeti in all scenes. I will roll back the project work when the problem was absent and as I progress, do tests of the issue paying attention to the assets/folders.

  • May 10, 2018 at 8:15 am #183772

    Justin – i updated clone2 with different character/atlases for all situations and made respective actions. All logic of movements is correct and all parts(movements) display without red X. The result is that it does not freeze completely as previously. Instead is has noticeable delays when player approaches and starts fight. It is not good UX. I am wondering what causes such freeze delays and how to address it. Please advise. Thanks!

    • May 10, 2018 at 8:50 am #183775

      Sorry, found the reason – renamed malee animation slowed it down. Its name in plist should not be changed upon changing character actions while using the same throw effect.

You must be logged in to reply to this topic.

Download the new CartoonSmart TV App - Tons of FREE and Premium Lessons

It's Free Right? Sure, I'll Get It!