MainMenu Button Sounds and Responsiveness in standard kit

Home 4 Forums iOS / tvOS Starter Kits The Role Playing Games iOS and tvOS Starter Kit MainMenu Button Sounds and Responsiveness in standard kit

This topic contains 2 replies, has 2 voices, and was last updated by  Universe 5 days, 15 hours ago.

  • May 14, 2018 at 8:21 pm #183854

    Hello
    Two questions around buttons in MainMenu. I feel it is important as being one of the first experiences for the user starting the game play.
    1) The plist indicates that buttons in MainMenu shall play Select.caf.
    However, i cannot hear them (other sounds like in game scenes are ok). Anything i could check?
    2) The main menu buttons sometimes seems to be a bit unresponsive from user perspective.It can sometimes take 1-2 sec to wait till anything happens. Or need to touch/tap it several times (i can see in Xcode if it tapped or not).
    – While waiting the scene load, there is no sign to tell user that touching a button successfully took place. Maybe a gray out or something would be good to show to user that something is going on.
    – If there was at least sound to play to tell user that he/she successfully touched the button (above point 1).

    Thank you!

  • May 15, 2018 at 3:43 pm #183871

    Try swapping out a different sound altogether. Ideally you use ZERO content from the demo. The more unique your app looks (and sounds) from the demo, the better. You want your Apple Reviewer to see something they’ve never seen before.

    Every Button has a SelectedImage option. Thats what appears when the user taps down. Good thing to make use of. Again though, start to include all your own images (and tap down images).

    See if that helps enough. But if your initial SKS level is taking a while to load, you could first transition to a different Menu scene first (like you suggest a grey screen), and have that automatically jump into the game. All stuff already possible =)

  • May 20, 2018 at 9:40 am #184018

    Hi Justin

    Yes, found the selected button setting in plist. However, it appears not take any effect on MainMenu screen. I made a different kind of workaround with animation. But if it supposed to still work by showing selected mode in MainMenu (Start, Continue Reset), please advise what to look for. Thanks!

You must be logged in to reply to this topic.

Download the new CartoonSmart TV App - Tons of FREE and Premium Lessons

It's Free Right? Sure, I'll Get It!