Build Fail: Multiple Commands Produced

Home 4 Forums iOS / tvOS Starter Kits The Story Tellers Kit 2 for iOS or tvOS Apps Build Fail: Multiple Commands Produced

This topic contains 2 replies, has 2 voices, and was last updated by  Mark 9 months, 3 weeks ago.

  • January 27, 2019 at 11:47 pm #203159

    I’ve been building my Storyteller kit and running it in the simulator with no problems.

    Xcode suddenly quit and now I get “Multiple Command Produced…” build failure error when trying to build the project.

  • January 27, 2019 at 11:51 pm #203160

    Did you see this on Stack…

    https://stackoverflow.com/questions/50718018/xcode-10-error-multiple-commands-produce

    I think you might have two of the same thing added to the Project. It can happen.

    I don’t think it has anything to do with that “Legacy Build System” that someone suggested.

  • January 28, 2019 at 4:18 pm #203177

    Checked out Stack. Lot’s of information…

    I decided to remove the info.plist from Copy Bundle Resources under Build Phases.

    The project would build (with Project Setting on New Build…

    I then noticed under the Project files (left panel) in the project that info.plist did not have Target Membership with StoryTellerKit2 – checked it and it still builds (and the info.plist, which I removed, is added back into the Copy Bundle Resources).

    This solved the problem.

You must be logged in to reply to this topic.




Become part of the CartoonSmart Team with our Affiliate Program

Make recurring money when you refer a subscriber. 30 day tracking. Commissions 33%-50%!


Uh oh, missing your affiliate ID. Create one real quick